<!DOCTYPE html>
<html lang="en-GB" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://wired868.com/xmlrpc.php" />
<title>Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime” &#8211; Wired868</title>
<meta property="og:title" content="Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime” - Wired868"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="“The refusal to implement 21st century ideology into the police force means a continuation of a weak"/>
<meta property="og:url" content="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/"/>
<meta property="og:site_name" content="Wired868"/>
<meta property="og:image" content="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-ftr-600x330.jpg?x71639" />
<!-- JM Twitter Cards by Julien Maury 7.6.0 -->
<meta name="twitter:card" content="summary">
<meta name="twitter:creator" content="@lasanaliburd">
<meta name="twitter:site" content="@wired868">
<meta name="twitter:title" content="Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”">
<meta name="twitter:description" content="“The refusal to implement 21st century ideology into the police force means a continuation of a weak police infrastructure. It means a continuation of the lack of accountability within a sector that">
<meta name="twitter:image" content="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-ftr.jpg?x71639">
<!-- /JM Twitter Cards by Julien Maury 7.6.0 -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Wired868 &raquo; Feed" href="http://wired868.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wired868 &raquo; Comments Feed" href="http://wired868.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wired868 &raquo; Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime” Comments Feed" href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/wired868.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='taqyeem-style-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/taqyeem/style.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/captcha/css/front_end_style.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-includes/css/dashicons.min.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_mobile_style-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/captcha/css/mobile_style.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-crestafont-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/cresta-social-share-counter/css/csscfont.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-wp-style-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/cresta-social-share-counter/css/cresta-wp-css.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-googlefonts-css'  href='//fonts.googleapis.com/css?family=Noto+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-video-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/responsive-video/css/responsive-videos.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-general-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/sportspress/assets/css/sportspress.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-icons-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/sportspress/assets/css/icons.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-roboto-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C500&#038;subset=cyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-style-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/sportspress/assets/css/sportspress-style.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-style-ltr-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/sportspress/assets/css/sportspress-style-ltr.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-buttons-style-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/taqyeem-buttons/assets/style.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='display-authors-widget-styles-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/display-authors-widget/css/display-authors-widget.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/style.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='http://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='instag-slider-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/instagram-slider-widget/assets/css/instag-slider.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?x71639' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/jetpack/css/jetpack.css?x71639' type='text/css' media='all' />
<style type="text/css"></style><script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-includes/js/jquery/jquery.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-includes/js/jquery/jquery-migrate.min.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/taqyeem/js/tie.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/instagram-slider-widget/assets/js/jquery.flexslider-min.js?x71639'></script>
<link rel='https://api.w.org/' href='http://wired868.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://wired868.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff' href='http://wired868.com/2017/02/02/ttfa-promises-retainer-contracts-morace-brings-three-foreign-coaches-on-womens-staff/' />
<meta name="generator" content="WordPress 4.6.3" />
<meta name="generator" content="SportsPress 2.2.3" />
<link rel="canonical" href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/" />
<link rel='shortlink' href='http://wp.me/p4k9te-9pQ' />
<link rel="alternate" type="application/json+oembed" href="http://wired868.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwired868.com%2F2017%2F02%2F03%2Flimited-thinking-why-tt-governments-get-nowhere-in-war-on-crime%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://wired868.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwired868.com%2F2017%2F02%2F03%2Flimited-thinking-why-tt-governments-get-nowhere-in-war-on-crime%2F&#038;format=xml" />
<style type='text/css'>.cresta-share-icon .sbutton {text-shadow: 1px 1px 0px rgba(0, 0, 0, .4);}</style><script type='text/javascript'>
/* <![CDATA[ */
var taqyeem = {"ajaxurl":"http://wired868.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};
/* ]]> */
</script>
<style type="text/css" media="screen"> 

</style> 

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel="shortcut icon" href="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/05/favicon.ico?x71639" title="Favicon" />	
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->	
<!--[if lt IE 9]>
<script src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/js/html5.js?x71639"></script>
<script src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/js/selectivizr-min.js?x71639"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/css/ie9.css?x71639" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/css/ie8.css?x71639" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/css/ie7.css?x71639" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />



<style type="text/css" media="screen"> 

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #ef3636;
}
	
.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#ef3636;
}

::-webkit-scrollbar-thumb{
	background-color:#ef3636 !important;
}
	
#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box { 
	border-top-color: #ef3636;
}
	
.search-block:after {
	border-right-color:#ef3636;
}

body.rtl .search-block:after {
	border-left-color:#ef3636;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #ef3636;
}
	
.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #ef3636;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #ef3636;
	border-color: #ef3636;
}

#order_review,
#order_review_heading {
	border-color: #ef3636;
}


a {
	color: #7a7a7a;
	text-decoration: none;
}
		
a:hover {
	color: #8f8f8f;
	text-decoration: underline;
}
		
</style> 

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"http:\/\/wired868.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"http:\/\/wired868.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		
<!-- WordPress Facebook Open Graph protocol plugin (WPFBOGP v2.0.13) http://rynoweb.com/wordpress-plugins/ -->
<meta property="fb:app_id" content="484287708248345"/>
<meta property="og:url" content="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/"/>
<meta property="og:title" content="Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”"/>
<meta property="og:site_name" content="Wired868"/>
<meta property="og:description" content="“The refusal to implement 21st century ideology into the police force means a continuation of a weak police infrastructure. It means a continuation of the lac"/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-ftr-600x338.jpg?x71639"/>
<meta property="og:image" content="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar.jpg?x71639"/>
<meta property="og:image" content="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/edmund-dillon-cnc3.jpg?x71639"/>
<meta property="og:image" content="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/five-families-mob.jpg?x71639"/>
<meta property="og:image" content="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/police-stephen-williams-guardian.jpg?x71639"/>
<meta property="og:image" content="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/Kamla-and-keith-Rowley-power102fm.jpg?x71639"/>
<meta property="og:locale" content="en_gb"/>
<!-- // end wpfbogp -->
</head>
<body id="top" class="single single-post postid-36198 single-format-standard lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">
	
			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="http://wired868.com/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>	
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
		
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="http://wired868.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/u/0/106801319776179833488/posts" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/Wired868/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/Wired868" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="LinkedIn" href="https://www.linkedin.com/in/lasana-liburd-b00291b" target="_blank"><i class="fa fa-linkedin"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/wired868/" target="_blank"><i class="tieicon-instagram"></i></a>		
			</div>

		
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Friday , February 3 2017</span>					
				<div class="menu"><ul><li class="page_item page-item-11583"><a href="http://wired868.com/about-us/">About Us</a></li><li class="page_item page-item-3348"><a href="http://wired868.com/advertising/">Advertising</a></li><li class="page_item page-item-8"><a href="http://wired868.com/blog/">Blog</a></li><li class="page_item page-item-3350"><a href="http://wired868.com/contact-us/">Contact Us</a></li><li class="page_item page-item-3346"><a href="http://wired868.com/contributors/">Contributors</a></li><li class="page_item page-item-3450"><a href="http://wired868.com/">Home</a></li><li class="page_item page-item-6"><a href="http://wired868.com/latest/">Latest Posts</a></li></ul></div>

						<div class="search-block">
						<form method="get" id="searchform-header" action="http://wired868.com/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>	
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="http://wired868.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/u/0/106801319776179833488/posts" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/Wired868/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/Wired868" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="LinkedIn" href="https://www.linkedin.com/in/lasana-liburd-b00291b" target="_blank"><i class="fa fa-linkedin"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/wired868/" target="_blank"><i class="tieicon-instagram"></i></a>		
			</div>

		
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">
		
					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
				
			<div class="logo" style=" margin-top:15px; margin-bottom:15px;">
			<h2>								<a title="Wired868" href="http://wired868.com/">
					<img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/02/wired-868-logo2-300x82.png?x71639" alt="Wired868"  /><strong>Wired868 Wired868 for smart sport news and satire</strong>
				</a>
			</h2>			</div><!-- .logo /-->
						<div class="clear"></div>
			
		</div>	
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">
				
				
					<div class="main-menu"><ul id="menu-cat-nav" class="menu"><li id="menu-item-28238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28238"><a href="http://wired868.com/"><i class="fa fa-home"></i>Home</a></li>
<li id="menu-item-11555" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-11555 mega-menu mega-recent-featured "><a href="http://wired868.com/category/volley/"><i class="fa fa-comments-o"></i>Volley</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-28351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28351"><a href="http://wired868.com/category/volley/local-sport-2/">Local Football</a></li>
	<li id="menu-item-28353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28353"><a href="http://wired868.com/category/volley/tt-national-teams/">National Football</a></li>
	<li id="menu-item-28352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28352"><a href="http://wired868.com/category/volley/international-sport/">Global Football</a></li>
	<li id="menu-item-28354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28354"><a href="http://wired868.com/category/volley/cricket/">Cricket</a></li>
	<li id="menu-item-28355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28355"><a href="http://wired868.com/category/volley/world-cup/">Other Sports</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/02/02/ttfa-promises-retainer-contracts-morace-brings-three-foreign-coaches-on-womens-staff/" title="TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/women-nicola-williams-carolina-morace-david-john-williams-elisabetta-bavagnoli-ftr-600x330.jpg?x71639" width="660" height="330" alt="TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/02/02/ttfa-promises-retainer-contracts-morace-brings-three-foreign-coaches-on-womens-staff/" title="TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff">TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 2 February 2017</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/02/02/many-rivers-to-cross-club-sando-star-kemuel-talks-about-football-life-and-jail/" title="Many Rivers to cross: Club Sando star, Kemuel, talks about football, life and jail"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/10/sando-kemuel-rivers-connection-ftr-110x75.jpg?x71639" width="110" height="75" alt="Many Rivers to cross: Club Sando star, Kemuel, talks about football, life and jail" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/02/02/many-rivers-to-cross-club-sando-star-kemuel-talks-about-football-life-and-jail/" title="Many Rivers to cross: Club Sando star, Kemuel, talks about football, life and jail">Many Rivers to cross: Club Sando star, Kemuel, talks about football, life and jail</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 2 February 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/02/01/pro-bowl-qualifiers-police-fc-rout-point-fortin-civic-9-0-st-anns-edge-mvt-cale/" title="Pro Bowl results: Police FC rout Point Fortin Civic 9-0; St Ann’s edge M’vt Cale"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/11/police-kadeem-riley-civic-shevhon-abraham-ftr-110x75.jpg?x71639" width="110" height="75" alt="Pro Bowl results: Police FC rout Point Fortin Civic 9-0; St Ann’s edge M’vt Cale" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/02/01/pro-bowl-qualifiers-police-fc-rout-point-fortin-civic-9-0-st-anns-edge-mvt-cale/" title="Pro Bowl results: Police FC rout Point Fortin Civic 9-0; St Ann’s edge M’vt Cale">Pro Bowl results: Police FC rout Point Fortin Civic 9-0; St Ann’s edge M’vt Cale</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Wednesday 1 February 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/" title="“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/07/darryl-smith-naaa-ephraim-serrette-2016-ftr-110x75.jpg?x71639" width="110" height="75" alt="“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/" title="“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes">“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Wednesday 1 February 2017</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-11564" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11564 mega-menu mega-cat "><a href="http://wired868.com/category/view-point/"><i class="fa fa-quote-left"></i>View Point</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-cat-wrapper">  <div class="mega-cat-content"><div id="mega-cat-11564-28" class="mega-cat-content-tab"><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/" title="Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-ftr-310x165.jpg?x71639" width="310" height="165" alt="Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/" title="Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”">Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>Friday 3 February 2017</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/01/29/the-negative-progress-of-the-trini-paradox-the-price-for-mixing-sheep-and-goat/" title="The negative progress of the Trini paradox; the price for mixing sheep and goat"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/strip-club-pole-dancer-literaryhub-ftr-310x165.jpg?x71639" width="310" height="165" alt="The negative progress of the Trini paradox; the price for mixing sheep and goat" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/01/29/the-negative-progress-of-the-trini-paradox-the-price-for-mixing-sheep-and-goat/" title="The negative progress of the Trini paradox; the price for mixing sheep and goat">The negative progress of the Trini paradox; the price for mixing sheep and goat</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>Sunday 29 January 2017</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/01/28/letter-to-editor-uber-tter-help-ph-drivers-too-new-taxi-service-can-solve-old-problem/" title="Letter to Editor: Uber-tter help PH drivers too! New taxi service can solve old problem"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/uber-driver-ftr-310x165.jpg?x71639" width="310" height="165" alt="Letter to Editor: Uber-tter help PH drivers too! New taxi service can solve old problem" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/01/28/letter-to-editor-uber-tter-help-ph-drivers-too-new-taxi-service-can-solve-old-problem/" title="Letter to Editor: Uber-tter help PH drivers too! New taxi service can solve old problem">Letter to Editor: Uber-tter help PH drivers too! New taxi service can solve old problem</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>Saturday 28 January 2017</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/01/22/the-big-pappy-life-daly-considers-the-perils-of-our-ultimate-rejects-lifestyle/" title="The ‘Big Pappy Life’: Daly considers the perils of our Ultimate Rejects lifestyle"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/carnival-looptt-ftr.jpg?x71639" width="310" height="165" alt="The ‘Big Pappy Life’: Daly considers the perils of our Ultimate Rejects lifestyle" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/01/22/the-big-pappy-life-daly-considers-the-perils-of-our-ultimate-rejects-lifestyle/" title="The ‘Big Pappy Life’: Daly considers the perils of our Ultimate Rejects lifestyle">The ‘Big Pappy Life’: Daly considers the perils of our Ultimate Rejects lifestyle</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>Sunday 22 January 2017</span>
							</div> <!-- mega-menu-post --></div><!-- .mega-cat-content-tab --> </div> <!-- .mega-cat-content --> 
								<div class="clear"></div>
							</div> <!-- .mega-cat-Wrapper --> 
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-11556" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11556 mega-menu mega-recent-featured "><a href="http://wired868.com/category/good-morning/"><i class="fa fa-sun-o"></i>Live Wire</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/01/27/the-sport-ministrys-chilling-secret-live-wire-puts-a-hand-on-minister-heavy-d-smith/" title="The Sport Ministry’s chilling secret; Live Wire puts a hand on Minister Heavy-D Smith"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/sport-darryl-smith-fitzgerald-hinds-ftr-600x330.jpg?x71639" width="660" height="330" alt="The Sport Ministry’s chilling secret; Live Wire puts a hand on Minister Heavy-D Smith" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/01/27/the-sport-ministrys-chilling-secret-live-wire-puts-a-hand-on-minister-heavy-d-smith/" title="The Sport Ministry’s chilling secret; Live Wire puts a hand on Minister Heavy-D Smith">The Sport Ministry’s chilling secret; Live Wire puts a hand on Minister Heavy-D Smith</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>Friday 27 January 2017</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/01/25/not-so-fast-t-live-wire-examines-golden-feat/" title="Live Wire: Not so fast! T&#038;T sprint quartet set to snatch Beijing 4&#215;100 crown off Jamaica"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/03/thompson-callender-burns-bledman-afp-ftr.jpg?x71639" width="110" height="75" alt="Live Wire: Not so fast! T&#038;T sprint quartet set to snatch Beijing 4&#215;100 crown off Jamaica" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/01/25/not-so-fast-t-live-wire-examines-golden-feat/" title="Live Wire: Not so fast! T&#038;T sprint quartet set to snatch Beijing 4&#215;100 crown off Jamaica">Live Wire: Not so fast! T&#038;T sprint quartet set to snatch Beijing 4&#215;100 crown off Jamaica</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Wednesday 25 January 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/01/12/unc-senator-for-gods-sake-lets-rape-children-live-wire-corners-waffie-on-quran/" title="UNC senator: For God’s sake, let’s rape children! Live Wire corners Waffie on Quran"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/09/Michelle-obama-bringbackourgirls-ftr.jpg?x71639" width="110" height="75" alt="UNC senator: For God’s sake, let’s rape children! Live Wire corners Waffie on Quran" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/01/12/unc-senator-for-gods-sake-lets-rape-children-live-wire-corners-waffie-on-quran/" title="UNC senator: For God’s sake, let’s rape children! Live Wire corners Waffie on Quran">UNC senator: For God’s sake, let’s rape children! Live Wire corners Waffie on Quran</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 12 January 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2017/01/12/sayonara-saintfiet-live-wire-bids-a-satirical-farewell-to-belgian-football-coach/" title="Sayonara Saintfiet: Live Wire bids a satirical farewell to Belgian football coach"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/12/Coach-Tom-Saintfiet-ethiosports-ftr-110x75.jpg?x71639" width="110" height="75" alt="Sayonara Saintfiet: Live Wire bids a satirical farewell to Belgian football coach" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2017/01/12/sayonara-saintfiet-live-wire-bids-a-satirical-farewell-to-belgian-football-coach/" title="Sayonara Saintfiet: Live Wire bids a satirical farewell to Belgian football coach">Sayonara Saintfiet: Live Wire bids a satirical farewell to Belgian football coach</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 12 January 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/12/29/jan-mar-2016-tim-kee-harikari-ians-cocolooks-contest-and-thema-vs-dick-dont-blush-baby/" title="Jan-Mar 2016: Tim Kee harikari, Ian&#8217;s cocolooks contest and Thema vs Dick&#8230; Don’t blush, baby!"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2014/05/ttfa-tim-kee-zurich-ftr.jpg?x71639" width="110" height="75" alt="Jan-Mar 2016: Tim Kee harikari, Ian&#8217;s cocolooks contest and Thema vs Dick&#8230; Don’t blush, baby!" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/12/29/jan-mar-2016-tim-kee-harikari-ians-cocolooks-contest-and-thema-vs-dick-dont-blush-baby/" title="Jan-Mar 2016: Tim Kee harikari, Ian&#8217;s cocolooks contest and Thema vs Dick&#8230; Don’t blush, baby!">Jan-Mar 2016: Tim Kee harikari, Ian&#8217;s cocolooks contest and Thema vs Dick&#8230; Don’t blush, baby!</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 29 December 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/12/22/iamcorbeau-shannon-ploitation-perverted-justice-and-countess-camille-of-chaguaramas/" title="#iamcorbeau&#8230; Shannon-ploitation, perverted justice and Countess Camille of Chaguaramas"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/12/vulture-corbeau-cartoon-ftr-110x75.jpg?x71639" width="110" height="75" alt="#iamcorbeau&#8230; Shannon-ploitation, perverted justice and Countess Camille of Chaguaramas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/12/22/iamcorbeau-shannon-ploitation-perverted-justice-and-countess-camille-of-chaguaramas/" title="#iamcorbeau&#8230; Shannon-ploitation, perverted justice and Countess Camille of Chaguaramas">#iamcorbeau&#8230; Shannon-ploitation, perverted justice and Countess Camille of Chaguaramas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 22 December 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/11/29/were-just-not-that-into-you-live-wire-looks-at-2016-local-govt-election-results/" title="We’re just not that into you! Live Wire looks at 2016 local gov’t election results"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/kamla-and-keith-rowley-stabroek-news-ftr-110x75.jpg?x71639" width="110" height="75" alt="We’re just not that into you! Live Wire looks at 2016 local gov’t election results" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/11/29/were-just-not-that-into-you-live-wire-looks-at-2016-local-govt-election-results/" title="We’re just not that into you! Live Wire looks at 2016 local gov’t election results">We’re just not that into you! Live Wire looks at 2016 local gov’t election results</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Tuesday 29 November 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-11527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11527"><a href="http://wired868.com/category/about-us/"><i class="fa fa-envelope-o"></i>About Us</a></li>
<li id="menu-item-11566" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11566"><a href="http://wired868.com/category/friends/"><i class="fa fa-chain-broken"></i>Friends</a></li>
<li id="menu-item-15703" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15703 mega-menu mega-links mega-links-4col "><a href="http://wired868.com/contributors/"><i class="fa fa-pencil-square-o"></i>Contributors</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">

</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-31850" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31850 mega-menu mega-recent-featured "><a href="http://wired868.com/category/rio-2016/"><i class="fa fa-trophy"></i>Rio 2016</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/09/25/rio-review-thompson-jehue-cleopatra-and-callender-share-the-real-olympics-story/" title="Rio review: Thompson, Jehue, Cleopatra and Callender share the real Olympics story"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/rio-keshorn-walcott-throw-avc-ftr-600x330.jpg?x71639" width="660" height="330" alt="Rio review: Thompson, Jehue, Cleopatra and Callender share the real Olympics story" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/09/25/rio-review-thompson-jehue-cleopatra-and-callender-share-the-real-olympics-story/" title="Rio review: Thompson, Jehue, Cleopatra and Callender share the real Olympics story">Rio review: Thompson, Jehue, Cleopatra and Callender share the real Olympics story</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>Sunday 25 September 2016</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/09/10/ttoc-akeem-stewarts-golden-throw-could-be-game-changer-for-differently-abled/" title="TTOC: Akeem Stewart’s golden throw could be game changer for differently-abled"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/akeem-stewart-gold-javelin-rio2016-ftr-110x75.jpg?x71639" width="110" height="75" alt="TTOC: Akeem Stewart’s golden throw could be game changer for differently-abled" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/09/10/ttoc-akeem-stewarts-golden-throw-could-be-game-changer-for-differently-abled/" title="TTOC: Akeem Stewart’s golden throw could be game changer for differently-abled">TTOC: Akeem Stewart’s golden throw could be game changer for differently-abled</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Saturday 10 September 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/09/08/what-they-say-they-say-keshorn-walcott-talks-rio-2016-critics-and-tt-sport/" title="What they say, they say! Keshorn Walcott talks Rio 2016, critics and T&#038;T sport&#8230;"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/rio-keshorn-walcott-medal-ftr-110x75.jpg?x71639" width="110" height="75" alt="What they say, they say! Keshorn Walcott talks Rio 2016, critics and T&#038;T sport&#8230;" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/09/08/what-they-say-they-say-keshorn-walcott-talks-rio-2016-critics-and-tt-sport/" title="What they say, they say! Keshorn Walcott talks Rio 2016, critics and T&#038;T sport&#8230;">What they say, they say! Keshorn Walcott talks Rio 2016, critics and T&#038;T sport&#8230;</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 8 September 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/09/06/our-olympic-athletes-did-their-best-we-did-not-griffith-politicians-are-to-blame/" title="Our Olympic athletes did their best, we did not; Griffith: Politicians are to blame"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/rio-jehue-gordon-hurdles-ftr-110x75.jpg?x71639" width="110" height="75" alt="Our Olympic athletes did their best, we did not; Griffith: Politicians are to blame" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/09/06/our-olympic-athletes-did-their-best-we-did-not-griffith-politicians-are-to-blame/" title="Our Olympic athletes did their best, we did not; Griffith: Politicians are to blame">Our Olympic athletes did their best, we did not; Griffith: Politicians are to blame</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Tuesday 6 September 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/09/03/ttoc-ian-hypolite-did-not-duck-duties-as-chef-de-mission-for-espn-gig/" title="TTOC: Dr Ian Hypolite did not duck chef de mission duties for ESPN gig"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/rio-jarrin-solomon-lalonde-gordon-relay-ftr-110x75.jpg?x71639" width="110" height="75" alt="TTOC: Dr Ian Hypolite did not duck chef de mission duties for ESPN gig" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/09/03/ttoc-ian-hypolite-did-not-duck-duties-as-chef-de-mission-for-espn-gig/" title="TTOC: Dr Ian Hypolite did not duck chef de mission duties for ESPN gig">TTOC: Dr Ian Hypolite did not duck chef de mission duties for ESPN gig</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Saturday 3 September 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/08/28/wishful-thinking-of-olympian-proportions-daly-looks-from-dick-to-hypolite-and-in-between/" title="Wishful thinking of Olympian proportions: Daly looks from Dick to Hypolite and in-between"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/rio-machel-cedenio-salute-ftr-110x75.jpg?x71639" width="110" height="75" alt="Wishful thinking of Olympian proportions: Daly looks from Dick to Hypolite and in-between" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/08/28/wishful-thinking-of-olympian-proportions-daly-looks-from-dick-to-hypolite-and-in-between/" title="Wishful thinking of Olympian proportions: Daly looks from Dick to Hypolite and in-between">Wishful thinking of Olympian proportions: Daly looks from Dick to Hypolite and in-between</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Sunday 28 August 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://wired868.com/2016/08/20/raucous-in-rio-keshie-keshie-coo-its-a-bronze-trinidad-and-tobago/" title="Raucous in Rio: Keshie, Keshie, coo; It’s a bronze, Trinidad and Tobago!"><img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/rio-keshorn-walcott-medal-ftr-110x75.jpg?x71639" width="110" height="75" alt="Raucous in Rio: Keshie, Keshie, coo; It’s a bronze, Trinidad and Tobago!" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://wired868.com/2016/08/20/raucous-in-rio-keshie-keshie-coo-its-a-bronze-trinidad-and-tobago/" title="Raucous in Rio: Keshie, Keshie, coo; It’s a bronze, Trinidad and Tobago!">Raucous in Rio: Keshie, Keshie, coo; It’s a bronze, Trinidad and Tobago!</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>Saturday 20 August 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
</ul></div>										<a href="http://wired868.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a>
					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->
	
		
	<div class="clear"></div>
	<div id="breaking-news" class="breaking-news">
		<span class="breaking-news-title"><i class="fa fa-bolt"></i> <span>Breaking News</span></span>
		
					<ul>
					<li><a href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/" title="Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”">Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”</a></li>
					<li><a href="http://wired868.com/2017/02/02/ttfa-promises-retainer-contracts-morace-brings-three-foreign-coaches-on-womens-staff/" title="TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff">TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff</a></li>
					<li><a href="http://wired868.com/2017/02/02/many-rivers-to-cross-club-sando-star-kemuel-talks-about-football-life-and-jail/" title="Many Rivers to cross: Club Sando star, Kemuel, talks about football, life and jail">Many Rivers to cross: Club Sando star, Kemuel, talks about football, life and jail</a></li>
					<li><a href="http://wired868.com/2017/02/01/pro-bowl-qualifiers-police-fc-rout-point-fortin-civic-9-0-st-anns-edge-mvt-cale/" title="Pro Bowl results: Police FC rout Point Fortin Civic 9-0; St Ann’s edge M’vt Cale">Pro Bowl results: Police FC rout Point Fortin Civic 9-0; St Ann’s edge M’vt Cale</a></li>
					<li><a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/" title="“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes">“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes</a></li>
					<li><a href="http://wired868.com/2017/01/31/russia-2018-kenwyne-the-media-djw-wired868-reviews-lawrences-unveiling/" title="Russia 2018, Kenwyne, the media, DJW… Wired868 reviews Lawrence’s unveiling">Russia 2018, Kenwyne, the media, DJW… Wired868 reviews Lawrence’s unveiling</a></li>
					<li><a href="http://wired868.com/2017/01/31/letter-to-the-editor-olympic-sprinter-callender-speaks-out-about-representing-tt/" title="Letter to the Editor: Olympic sprinter, Callender, speaks out about representing T&#038;T">Letter to the Editor: Olympic sprinter, Callender, speaks out about representing T&#038;T</a></li>
					<li><a href="http://wired868.com/2017/01/30/lawrence-honoured-by-job-but-mum-on-details-sol-campbell-appointed-assistant-coach/" title="Lawrence honoured by T&#038;T job but mum on details; Sol Campbell appointed assistant coach">Lawrence honoured by T&#038;T job but mum on details; Sol Campbell appointed assistant coach</a></li>
					<li><a href="http://wired868.com/2017/01/29/letter-to-editor-how-ttsl-could-revolutionise-t-and-why-you-should-care/" title="Letter to Editor: How TTSL could revolutionise T&#038;T football; and why you should care!">Letter to Editor: How TTSL could revolutionise T&#038;T football; and why you should care!</a></li>
					<li><a href="http://wired868.com/2017/01/29/colombian-pro-team-signs-kimika-tt-womens-senior-and-u-20-teams-hold-trials/" title="Colombian pro team signs Kimika; T&#038;T women’s senior and U-20 teams hold trials">Colombian pro team signs Kimika; T&#038;T women’s senior and U-20 teams hold trials</a></li>
					</ul>
					
		
		<script type="text/javascript">
			jQuery(document).ready(function(){
								jQuery('#breaking-news ul').innerFade({animationType: 'fade', speed: 750 , timeout: 3500});
							});
					</script>
	</div> <!-- .breaking-news -->
	
	
	
	<div id="main-content" class="container">			
		
	
	
		
	<div class="content">
	
				
		<div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="http://wired868.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="http://wired868.com/category/view-point/">View Point</a></span> <span class="delimiter">/</span> <span class="current">Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”</span></div>
					
				
		<div class="e3lan e3lan-post">							</div>		
		
		
		<article class="post-listing post-36198 post type-post status-publish format-standard has-post-thumbnail hentry category-view-point tag-crime-plan tag-edmund-dillon tag-letter-to-the-editor tag-peoples-partnership tag-pnm tag-sheldon-waithe tag-state-of-emergency tag-unc" id="the-post">
			
			<div class="post-inner">
			
							<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="http://wired868.com/author/letters-to-the-editor/" title="">Letters to the Editor </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>Friday 3 February 2017</span>	
	<span class="post-cats"><i class="fa fa-folder"></i><a href="http://wired868.com/category/view-point/" rel="category tag">View Point</a></span>
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/#respond">Leave a comment</a></span>
</p>
<div class="clear"></div>
			
				<div class="entry">
					
					
					<p>“The refusal to implement 21st century ideology into the police force means a continuation of a weak police infrastructure. It means a continuation of the lack of accountability within a sector that has a rogue element that undermines its performance.</p>
<p>“When we continue inanely with systems that have failed us, the only explanation is that hands are tied by the real power brokers of the country.”</p>
<p><em>The following Letter to the Editor on the perceived limited thinking by the State in tackling crime was submitted to Wired868 by Sheldon Waithe</em>:</p>
<figure id="attachment_36197" style="width: 500px" class="wp-caption alignnone"><img class="size-full wp-image-36197" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar.jpg?x71639" alt="Photo: An actor playing late Colombian drug lord Pablo Escobar gestures with a bullet during the Netflix series, Narcos." width="500" height="282" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar.jpg?x71639 500w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-150x85.jpg?x71639 150w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-300x169.jpg?x71639 300w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-128x72.jpg?x71639 128w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-32x18.jpg?x71639 32w" sizes="(max-width: 500px) 100vw, 500px" /><figcaption class="wp-caption-text">Photo: An actor playing late Colombian drug lord Pablo Escobar gestures with a bullet during the Netflix series, Narcos.</figcaption></figure>
<p>A limited State of Emergency? Really? We did not learn from the last instance when this ultimate power in our Constitution was subject to heinous abuse and rolled out without explanation.</p>
<p>It is another glaring piece of evidence that we truly exchange one government for another, so we can expect the same toothless thinking from above. That it is being suggested from quarters outside the walls of Parliament points to the desperation of a helpless nation.</p>
<p>The State of Emergency of 2011 was a period where no long term or meaningful crime fighting initiatives were implemented; the then Government relied on the restriction of movement placed upon the entire nation to bring a stop to the murders and then crowed that between August and October there was a reduction in murders.</p>
<p>Even by the standard of this nation’s blind culture, it is absurd to expect that people would not see through the glaring hole that the idea to attack the daily erosion of our people, is to remove the rights of the entire population—and even then, it would not be used to implement a strategy that can ably tackle crime.</p>
<p>Any Trinbagonian government should recognise that once the normal failing national security system is back in place, then as a consequence the normal abysmal homicide rate would also be back in place.</p>
<figure id="attachment_33629" style="width: 500px" class="wp-caption alignnone"><img class="size-full wp-image-33629" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/edmund-dillon-cnc3.jpg?x71639" alt="Photo: Minister of National Security Edmund Dillon. (Copyright CNC3)" width="500" height="334" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/edmund-dillon-cnc3.jpg?x71639 500w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/edmund-dillon-cnc3-150x100.jpg?x71639 150w" sizes="(max-width: 500px) 100vw, 500px" /><figcaption class="wp-caption-text">Photo: Minister of National Security Edmund Dillon.<br />(Copyright CNC3)</figcaption></figure>
<p>The State of Emergency—begging your pardon, ‘Limited’—is supposed to show the seriousness of the government’s intent. A facade that there may be a crime plan on the horizon, so that in effect it masks the fact that there is no—and never was—a crime plan? We cannot go that route once again.</p>
<p>Trinidad and Tobago cannot have a strategic, meaningful crime plan until we have a government made up of individuals who are prepared to make the harsh decisions that can put a dent into crime.</p>
<p>The root causes of crime are not those persons killing or being killed as part of our daily headlines, they are not the ones with the network—it does not have to be elaborate to get past our current security systems—to bring in the weapons and drugs.</p>
<p>So, a government that is not prepared to target the root causes of crime cannot declare nor implement a crime plan, because that crime plan is doomed to failure. And a failed crime plan is bad Public Relations.</p>
<p>The reason that successive governments have not declared any type of long term action to tackle crime in this nation is that they cannot. The refusal to adopt a zero tolerance policy means playing into the hands at the end of the corruptive tentacles that run deep into every part of the society and that facilitates the inaction against the root causes of crime and more specifically, murders.</p>
<figure id="attachment_36195" style="width: 500px" class="wp-caption alignnone"><img class="size-full wp-image-36195" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/five-families-mob.jpg?x71639" alt="Photo: A crime boss relaxes in the shadows." width="500" height="282" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/five-families-mob.jpg?x71639 500w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/five-families-mob-150x85.jpg?x71639 150w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/five-families-mob-300x169.jpg?x71639 300w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/five-families-mob-128x72.jpg?x71639 128w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/five-families-mob-32x18.jpg?x71639 32w" sizes="(max-width: 500px) 100vw, 500px" /><figcaption class="wp-caption-text">Photo: A crime boss relaxes in the shadows.</figcaption></figure>
<p>How else do we explain governments—whether PNM, UNC or PP—refusing to take the hardline against crime?</p>
<p>The nation remains anchored with the appalling level of corruption in the society that means from the very top there is a culture of no accountability and therefore no reprimand.</p>
<p>In the decades of T&amp;T’s existence as a drugs capital, there has not been a single example of any major individual being tried and forced to serve time for the deeds that have also led to us being a murder capital of the world.</p>
<p>It is a pipe dream, for we would have to live in a society that was prepared to arrest such persons in the first instance, having targeted them and gained evidence.</p>
<p>The refusal to implement 21st century ideology into the police force means a continuation of a weak police infrastructure. It means a continuation of the lack of accountability within a sector that has a rogue element that undermines its performance.</p>
<p>When we continue inanely with systems that have failed us, the only explanation is that hands are tied by the real power brokers of the country.</p>
<p>What is the resistance to aid in the appointing of a permanent Commissioner of Police?</p>
<figure id="attachment_32328" style="width: 500px" class="wp-caption alignnone"><img class="size-full wp-image-32328" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/police-stephen-williams-guardian.jpg?x71639" alt="Photo: Acting Commissioner of Police Stephen Williams. (Copyright Trinidad Guardian)" width="500" height="465" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/police-stephen-williams-guardian.jpg?x71639 500w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/08/police-stephen-williams-guardian-150x140.jpg?x71639 150w" sizes="(max-width: 500px) 100vw, 500px" /><figcaption class="wp-caption-text">Photo: Acting Commissioner of Police Stephen Williams.<br />(Copyright Trinidad Guardian)</figcaption></figure>
<p>Or taking the logical approach of recognising that we simply do not have the ability within these borders to turn the tide against crime—the ever increasing murder rate over decades proves this, even if the current Acting Commissioner refuses to recognise that we are in crisis—and so we can import the expertise, mechanisms and personnel untainted by our local corruption?</p>
<p>The murder problem will take time to resolve, that can be appreciated, but at the moment there is nothing being done. <em>Nothing</em>.</p>
<p>Where do the Government and Opposition see this trajectory taking us if they do not deem the current situation to be of crisis proportions and to be tackled as <em>the</em> number one priority?</p>
<p>It is wrong to state that they are all clueless about tackling widespread crime; the correct assessment is that they are—for whatever reasons—unwilling to tackle rampant crime. Full stop.</p>
<p>Jamaica—whose crime rate we once used as a warning bell—is preparing to produce its strategic long term crime plan while T&amp;T tries to sweep the blood under the carpet with stats about violence being down or subliminal admissions that really, there is nothing that the forces feel they can do to alleviate the situation.</p>
<figure id="attachment_33210" style="width: 500px" class="wp-caption alignnone"><img class="size-full wp-image-33210" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/Kamla-and-keith-Rowley-power102fm.jpg?x71639" alt="Photo: Trinidad and Tobago Prime Minister Dr Keith Rowley (left) and Opposition Leader Kamla Persad-Bissessar SC. (Copyright Power102fm)" width="500" height="411" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/Kamla-and-keith-Rowley-power102fm.jpg?x71639 500w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/Kamla-and-keith-Rowley-power102fm-150x123.jpg?x71639 150w" sizes="(max-width: 500px) 100vw, 500px" /><figcaption class="wp-caption-text">Photo: Trinidad and Tobago Prime Minister Dr Keith Rowley (left) and Opposition Leader Kamla Persad-Bissessar SC.<br />(Copyright Power102fm)</figcaption></figure>
<p>The better approach would be to admit the problem, admit the inadequacies, then own it and change it.</p>
<p>Trinidad and Tobago is truly the land of limbo, for that is where our crime plan exists and every day the bar goes a little lower&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-36198" class="share-twitter sd-button share-icon no-text" href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-36198" class="share-facebook sd-button share-icon no-text" href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-36198" class="share-google-plus-1 sd-button share-icon no-text" href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>										
									</div><!-- .entry /-->
				<span style="display:none"><a href="http://wired868.com/tag/crime-plan/" rel="tag">crime plan</a> <a href="http://wired868.com/tag/edmund-dillon/" rel="tag">Edmund Dillon</a> <a href="http://wired868.com/tag/letter-to-the-editor/" rel="tag">Letter to the Editor</a> <a href="http://wired868.com/tag/peoples-partnership/" rel="tag">People's Partnership</a> <a href="http://wired868.com/tag/pnm/" rel="tag">PNM</a> <a href="http://wired868.com/tag/sheldon-waithe/" rel="tag">Sheldon Waithe</a> <a href="http://wired868.com/tag/state-of-emergency/" rel="tag">State of Emergency</a> <a href="http://wired868.com/tag/unc/" rel="tag">UNC</a></span>				<span style="display:none" class="updated">2017-02-03</span>
								<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="http://wired868.com/author/letters-to-the-editor/" title="Posts by Letters to the Editor" rel="author">Letters to the Editor</a></strong></div>
								
				<div class="share-post">
	<span class="share-text">Share</span>
	
		<script>
	window.___gcfg = {lang: 'en-US'};
	(function(w, d, s) {
	  function go(){
		var js, fjs = d.getElementsByTagName(s)[0], load = function(url, id) {
		  if (d.getElementById(id)) {return;}
		  js = d.createElement(s); js.src = url; js.id = id;
		  fjs.parentNode.insertBefore(js, fjs);
		};
		load('//connect.facebook.net/en/all.js#xfbml=1', 	'fbjssdk' );
		load('https://apis.google.com/js/plusone.js', 		'gplus1js');
		load('//platform.twitter.com/widgets.js', 			'tweetjs' );
	  }
	  if (w.addEventListener) { w.addEventListener("load", go, false); }
	  else if (w.attachEvent) { w.attachEvent("onload",go); }
	}(window, document, 'script'));
	</script>
	<ul class="normal-social">	
			<li>
			<div class="fb-like" data-href="http://wp.me/p4k9te-9pQ" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
		</li>
		
			<li><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://wp.me/p4k9te-9pQ" data-text="Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”" data-via="wired868" data-lang="en">tweet</a></li>
				<li style="width:80px;"><div class="g-plusone" data-size="medium" data-href="http://wp.me/p4k9te-9pQ"></div></li>
				<li><su:badge layout="2" location="http://wp.me/p4k9te-9pQ"></su:badge>
			<script type="text/javascript">
				(function() {
					var li = document.createElement('script'); li.type = 'text/javascript'; li.async = true;
					li.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//platform.stumbleupon.com/1/widgets.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(li, s);
				})();
			</script>
		</li>
				<li><script src="http://platform.linkedin.com/in.js" type="text/javascript"></script><script type="IN/Share" data-url="http://wp.me/p4k9te-9pQ" data-counter="right"></script></li>
				<li style="width:80px;"><script type="text/javascript" src="http://assets.pinterest.com/js/pinit.js"></script><a href="http://pinterest.com/pin/create/button/?url=http://wp.me/p4k9te-9pQ&amp;media=http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-ftr-600x330.jpg?x71639" class="pin-it-button" count-layout="horizontal"><img border="0" src="http://assets.pinterest.com/images/PinExt.png" title="Pin It" /></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->				<div class="clear"></div>
			</div><!-- .post-inner -->
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="http://wired868.com/tag/crime-plan/" rel="tag">crime plan</a> <a href="http://wired868.com/tag/edmund-dillon/" rel="tag">Edmund Dillon</a> <a href="http://wired868.com/tag/letter-to-the-editor/" rel="tag">Letter to the Editor</a> <a href="http://wired868.com/tag/peoples-partnership/" rel="tag">People's Partnership</a> <a href="http://wired868.com/tag/pnm/" rel="tag">PNM</a> <a href="http://wired868.com/tag/sheldon-waithe/" rel="tag">Sheldon Waithe</a> <a href="http://wired868.com/tag/state-of-emergency/" rel="tag">State of Emergency</a> <a href="http://wired868.com/tag/unc/" rel="tag">UNC</a></p>
		
		<div class="e3lan e3lan-post">							</div>		
				
		<section id="author-box">
			<div class="block-head">
				<h3>About Letters to the Editor </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/userphoto/313.thumbnail.jpg?x71639" alt="Letters to the Editor" width="80" height="60" class="photo" />	</div><!-- #author-avatar -->
			<div class="author-description">
						Want to share your thoughts with Wired868?
Email us at editor@wired868.com. Please keep your blog between 300 to 800 words and be sure to read it over first for typos and punctuation.		</div><!-- #author-description -->
		
		<div class="author-social flat-social">
				
										
							
				
													
		</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
				
		
						
		<div class="post-navigation">
			<div class="post-previous"><a href="http://wired868.com/2017/02/02/ttfa-promises-retainer-contracts-morace-brings-three-foreign-coaches-on-womens-staff/" rel="prev"><span>Previous</span> TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff</a></div>
			<div class="post-next"></div>
		</div><!-- .post-navigation -->
			
				
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="http://wired868.com/2017/01/29/the-negative-progress-of-the-trini-paradox-the-price-for-mixing-sheep-and-goat/">
					<img width="310" height="165" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/strip-club-pole-dancer-literaryhub-ftr-310x165.jpg?x71639" class="attachment-tie-medium size-tie-medium wp-post-image" alt="strip-club-pole-dancer-literaryhub-ftr" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="http://wired868.com/2017/01/29/the-negative-progress-of-the-trini-paradox-the-price-for-mixing-sheep-and-goat/" rel="bookmark">The negative progress of the Trini paradox; the price for mixing sheep and goat</a></h2>
			<p>Here is another test for the failed Acting Commissioner of Police, Stephen Williams and the &hellip;</p>
		</div>
			</section>
			
			
				
		
				
<div id="comments">

				<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://wired868.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="cptch_block"><script class="cptch_to_remove">
				(function( timeout ) {
					setTimeout(
						function() {
							var notice = document.getElementById("cptch_time_limit_notice_47");
							if ( notice )
								notice.style.display = "block";
						},
						timeout
					);
				})(120000);
			</script>
			<span id="cptch_time_limit_notice_47" class="cptch_time_limit_notice cptch_to_remove">Time limit is exhausted. Please reload CAPTCHA.</span><span class="cptch_wrap">
				<label class="cptch_label" for="cptch_input_47">
					<span class="cptch_span"><img class="cptch_img " src="data:image/png;base64,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" alt="image"/></span>
					<span class="cptch_span">&nbsp;&#43;&nbsp;</span>
					<span class="cptch_span">4</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_47" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<input type="hidden" name="cptch_result" value="Z5c+" />
					<input type="hidden" name="cptch_time" value="1486135508" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='36198' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>				</form>
					</div><!-- #respond -->
		<div class="clear"></div>





</div><!-- #comments -->
		
	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
<div id="search-2" class="widget widget_search"><div class="widget-top"><h4>Search</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><form role="search" method="get" class="search-form" action="http://wired868.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div></div><!-- .widget /--><div id="blog_subscription-3" class="widget jetpack_subscription_widget"><div class="widget-top"><h4>Subscribe</h4><div class="stripe-line"></div></div>
						<div class="widget-container">
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-3">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-3" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-3]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-3'),
					input = d.getElementById('subscribe-field-blog_subscription-3'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</div></div><!-- .widget /-->	<div class="widget" id="tabbed-widget">
		<div class="widget-container">
			<div class="widget-top">
				<ul class="tabs posts-taps">
				<li class="tabs"><a href="#tab2">Recent</a></li><li class="tabs"><a href="#tab1">Popular</a></li><li class="tabs"><a href="#tab3">Comments</a></li><li class="tabs"><a href="#tab4">Tags</a></li>				</ul>
			</div>
			
						<div id="tab2" class="tabs-wrap">
				<ul>
							<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/narcos-bullet-pablo-escobar-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="narcos-bullet-pablo-escobar-ftr" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://wired868.com/2017/02/03/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime/">Limited Thinking! Why T&#038;T Governments get nowhere in “war on crime”</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>Friday 3 February 2017</span>		</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/02/02/ttfa-promises-retainer-contracts-morace-brings-three-foreign-coaches-on-womens-staff/" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/women-nicola-williams-carolina-morace-david-john-williams-elisabetta-bavagnoli-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="Photo: Trinidad and Tobago Football Association (TTFA) president David John-Williams (second from right) poses with Women&#039;s National Senior Team coaches (from left) Nicola Williams, Carolina Morace and Elisabetta Bavagnoli at a press conference on 1 February 2017.
(Courtesy Sean Morrison/Wired868)" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/women-nicola-williams-carolina-morace-david-john-williams-elisabetta-bavagnoli-ftr-110x75.jpg?x71639 110w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/02/women-nicola-williams-carolina-morace-david-john-williams-elisabetta-bavagnoli-ftr-32x21.jpg?x71639 32w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://wired868.com/2017/02/02/ttfa-promises-retainer-contracts-morace-brings-three-foreign-coaches-on-womens-staff/">TTFA promises retainer contracts; Morace brings three foreign coaches on women’s staff</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 2 February 2017</span>		</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/02/02/many-rivers-to-cross-club-sando-star-kemuel-talks-about-football-life-and-jail/" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/10/sando-kemuel-rivers-connection-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="sando-kemuel-rivers-connection-ftr" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://wired868.com/2017/02/02/many-rivers-to-cross-club-sando-star-kemuel-talks-about-football-life-and-jail/">Many Rivers to cross: Club Sando star, Kemuel, talks about football, life and jail</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 2 February 2017</span>		</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/02/01/pro-bowl-qualifiers-police-fc-rout-point-fortin-civic-9-0-st-anns-edge-mvt-cale/" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/11/police-kadeem-riley-civic-shevhon-abraham-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="police-kadeem-riley-civic-shevhon-abraham-ftr" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://wired868.com/2017/02/01/pro-bowl-qualifiers-police-fc-rout-point-fortin-civic-9-0-st-anns-edge-mvt-cale/">Pro Bowl results: Police FC rout Point Fortin Civic 9-0; St Ann’s edge M’vt Cale</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>Wednesday 1 February 2017</span>		</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/07/darryl-smith-naaa-ephraim-serrette-2016-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="darryl-smith-naaa-ephraim-serrette-2016-ftr" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/07/darryl-smith-naaa-ephraim-serrette-2016-ftr-110x75.jpg?x71639 110w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/07/darryl-smith-naaa-ephraim-serrette-2016-ftr-32x21.jpg?x71639 32w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/">“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>Wednesday 1 February 2017</span>		</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/01/31/russia-2018-kenwyne-the-media-djw-wired868-reviews-lawrences-unveiling/" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/ttfa-dennis-lawrence-coach-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="ttfa-dennis-lawrence-coach-ftr" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/ttfa-dennis-lawrence-coach-ftr-110x75.jpg?x71639 110w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/ttfa-dennis-lawrence-coach-ftr-32x21.jpg?x71639 32w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://wired868.com/2017/01/31/russia-2018-kenwyne-the-media-djw-wired868-reviews-lawrences-unveiling/">Russia 2018, Kenwyne, the media, DJW… Wired868 reviews Lawrence’s unveiling</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>Tuesday 31 January 2017</span>		</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/01/31/letter-to-the-editor-olympic-sprinter-callender-speaks-out-about-representing-tt/" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/emmanuel-callender-afp-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="emmanuel-callender-afp-ftr" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/emmanuel-callender-afp-ftr-110x75.jpg?x71639 110w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/emmanuel-callender-afp-ftr-32x21.jpg?x71639 32w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://wired868.com/2017/01/31/letter-to-the-editor-olympic-sprinter-callender-speaks-out-about-representing-tt/">Letter to the Editor: Olympic sprinter, Callender, speaks out about representing T&#038;T</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>Tuesday 31 January 2017</span>		</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/01/30/lawrence-honoured-by-job-but-mum-on-details-sol-campbell-appointed-assistant-coach/" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/sol-campbell-kenya-afp-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="sol-campbell-kenya-afp-ftr" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/sol-campbell-kenya-afp-ftr-110x75.jpg?x71639 110w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2017/01/sol-campbell-kenya-afp-ftr-32x21.jpg?x71639 32w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://wired868.com/2017/01/30/lawrence-honoured-by-job-but-mum-on-details-sol-campbell-appointed-assistant-coach/">Lawrence honoured by T&#038;T job but mum on details; Sol Campbell appointed assistant coach</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>Monday 30 January 2017</span>		</li>
			
				</ul>
			</div>
						<div id="tab1" class="tabs-wrap">
				<ul>
								<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2016/12/06/ttfa-set-to-name-obscure-belgian-as-coach-saintfiet-once-blanked-permit-by-zimbabwe/" title="TTFA set to appoint obscure Belgian; ex-Bangladesh coach asked to take T&#038;T to World Cup" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/12/Coach-Tom-Saintfiet-ethiosports-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="coach-tom-saintfiet-ethiosports-ftr" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
							<h3><a href="http://wired868.com/2016/12/06/ttfa-set-to-name-obscure-belgian-as-coach-saintfiet-once-blanked-permit-by-zimbabwe/">TTFA set to appoint obscure Belgian; ex-Bangladesh coach asked to take T&#038;T to World Cup</a></h3>
				 <span class="tie-date"><i class="fa fa-clock-o"></i>Tuesday 6 December 2016</span>								<span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="http://wired868.com/2016/12/06/ttfa-set-to-name-obscure-belgian-as-coach-saintfiet-once-blanked-permit-by-zimbabwe/#comments">971</a></span>
							</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2016/01/04/eye-of-the-tiger-gayle-sparks-outrage-with-swing-and-miss-at-aussie-presenter/" title="Eye of the Tiger: Gayle sparks outrage with swing and miss at Aussie presenter" rel="bookmark"><img width="110" height="62" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/chris-gayle-mel-news-com-au-ftr.jpeg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="chris-gayle-mel-news-com-au-ftr" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/chris-gayle-mel-news-com-au-ftr.jpeg?x71639 600w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/chris-gayle-mel-news-com-au-ftr-150x85.jpeg?x71639 150w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/chris-gayle-mel-news-com-au-ftr-500x282.jpeg?x71639 500w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
							<h3><a href="http://wired868.com/2016/01/04/eye-of-the-tiger-gayle-sparks-outrage-with-swing-and-miss-at-aussie-presenter/">Eye of the Tiger: Gayle sparks outrage with swing and miss at Aussie presenter</a></h3>
				 <span class="tie-date"><i class="fa fa-clock-o"></i>Monday 4 January 2016</span>								<span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="http://wired868.com/2016/01/04/eye-of-the-tiger-gayle-sparks-outrage-with-swing-and-miss-at-aussie-presenter/#comments">562</a></span>
							</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2016/01/13/fixin-tt-rowley-must-remove-marlene-mcdonald-immediately/" title="Fixin’ T&#038;T: Rowley must remove Marlene McDonald immediately" rel="bookmark"><img width="110" height="73" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/marlene-mcdonald-andy-hypolite-guardian-ftr.jpeg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="marlene-mcdonald-andy-hypolite-guardian-ftr" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/marlene-mcdonald-andy-hypolite-guardian-ftr.jpeg?x71639 600w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/marlene-mcdonald-andy-hypolite-guardian-ftr-150x100.jpeg?x71639 150w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/01/marlene-mcdonald-andy-hypolite-guardian-ftr-500x333.jpeg?x71639 500w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
							<h3><a href="http://wired868.com/2016/01/13/fixin-tt-rowley-must-remove-marlene-mcdonald-immediately/">Fixin’ T&#038;T: Rowley must remove Marlene McDonald immediately</a></h3>
				 <span class="tie-date"><i class="fa fa-clock-o"></i>Wednesday 13 January 2016</span>								<span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="http://wired868.com/2016/01/13/fixin-tt-rowley-must-remove-marlene-mcdonald-immediately/#comments">505</a></span>
							</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2016/05/09/grayson-sarjeant-and-cyrus-speak-out-on-shock-dismissals-at-st-augustine-and-st-benedicts/" title="Grayson, Sarjeant and Cyrus speak out on shock dismissals at St Augustine and St Benedict’s" rel="bookmark"><img width="110" height="73" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/10/bede-marlon-phillip-fatima-ftr.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="bede-marlon-phillip-fatima-ftr" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/10/bede-marlon-phillip-fatima-ftr.jpg?x71639 600w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/10/bede-marlon-phillip-fatima-ftr-150x100.jpg?x71639 150w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/10/bede-marlon-phillip-fatima-ftr-500x333.jpg?x71639 500w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
							<h3><a href="http://wired868.com/2016/05/09/grayson-sarjeant-and-cyrus-speak-out-on-shock-dismissals-at-st-augustine-and-st-benedicts/">Grayson, Sarjeant and Cyrus speak out on shock dismissals at St Augustine and St Benedict’s</a></h3>
				 <span class="tie-date"><i class="fa fa-clock-o"></i>Monday 9 May 2016</span>								<span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="http://wired868.com/2016/05/09/grayson-sarjeant-and-cyrus-speak-out-on-shock-dismissals-at-st-augustine-and-st-benedicts/#comments">496</a></span>
							</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2016/12/16/saintfiet-allegedly-knocks-sanchos-third-world-mentality-central-block-players-from-tt-training/" title="Saintfiet allegedly knocks Sancho’s third world mentality; Central block players from T&#038;T training" rel="bookmark"><img width="103" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/09/brent-sancho-siparia-ftr.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="AUG 26TH 2015:During the Opening of Irwin Park Sporting Complex in Siparia. Photo: Allan V. Crane" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/09/brent-sancho-siparia-ftr.jpg?x71639 600w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/09/brent-sancho-siparia-ftr-150x109.jpg?x71639 150w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/09/brent-sancho-siparia-ftr-500x363.jpg?x71639 500w" sizes="(max-width: 103px) 100vw, 103px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
							<h3><a href="http://wired868.com/2016/12/16/saintfiet-allegedly-knocks-sanchos-third-world-mentality-central-block-players-from-tt-training/">Saintfiet allegedly knocks Sancho’s third world mentality; Central block players from T&#038;T training</a></h3>
				 <span class="tie-date"><i class="fa fa-clock-o"></i>Friday 16 December 2016</span>								<span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="http://wired868.com/2016/12/16/saintfiet-allegedly-knocks-sanchos-third-world-mentality-central-block-players-from-tt-training/#comments">479</a></span>
							</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2016/11/24/ttfa-goes-hart-less-john-williams-announces-departure-of-soca-warriors-coach/" title="TTFA goes Hart-less: John-Williams sacks Soca Warriors coach at Ruby Tuesdays" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/05/warriors-stephen-hart-david-john-williams-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="warriors-stephen-hart-david-john-williams-ftr" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
							<h3><a href="http://wired868.com/2016/11/24/ttfa-goes-hart-less-john-williams-announces-departure-of-soca-warriors-coach/">TTFA goes Hart-less: John-Williams sacks Soca Warriors coach at Ruby Tuesdays</a></h3>
				 <span class="tie-date"><i class="fa fa-clock-o"></i>Thursday 24 November 2016</span>								<span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="http://wired868.com/2016/11/24/ttfa-goes-hart-less-john-williams-announces-departure-of-soca-warriors-coach/#comments">473</a></span>
							</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2016/10/04/letter-to-the-editor-thats-insulting-condescending-politicians-are-tts-biggest-freeloaders/" title="Letter to the Editor: That’s insulting! Condescending politicians are T&#038;T’s biggest freeloaders" rel="bookmark"><img width="110" height="75" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2016/09/keith-rowley-caribbeannewsservice-ftr-110x75.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="keith-rowley-caribbeannewsservice-ftr" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
							<h3><a href="http://wired868.com/2016/10/04/letter-to-the-editor-thats-insulting-condescending-politicians-are-tts-biggest-freeloaders/">Letter to the Editor: That’s insulting! Condescending politicians are T&#038;T’s biggest freeloaders</a></h3>
				 <span class="tie-date"><i class="fa fa-clock-o"></i>Tuesday 4 October 2016</span>								<span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="http://wired868.com/2016/10/04/letter-to-the-editor-thats-insulting-condescending-politicians-are-tts-biggest-freeloaders/#comments">434</a></span>
							</li>
				<li >
						
				<div class="post-thumbnail">
					<a href="http://wired868.com/2017/01/02/aunt-phyllis-saintfiet-is-defaming-cyrus-tt-defender-had-just-one-glass-of-baileys/" title="Aunt Phyllis: Saintfiet is defaming Cyrus; T&#038;T defender had just one glass of Bailey’s!" rel="bookmark"><img width="110" height="67" src="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/07/warriors-cyrus-celebrate-guatemala-ftr.jpg?x71639" class="attachment-tie-small size-tie-small wp-post-image" alt="warriors-cyrus-celebrate-guatemala-ftr" srcset="http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/07/warriors-cyrus-celebrate-guatemala-ftr.jpg?x71639 600w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/07/warriors-cyrus-celebrate-guatemala-ftr-150x92.jpg?x71639 150w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/07/warriors-cyrus-celebrate-guatemala-ftr-500x307.jpg?x71639 500w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/07/warriors-cyrus-celebrate-guatemala-ftr-120x72.jpg?x71639 120w, http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/07/warriors-cyrus-celebrate-guatemala-ftr-241x145.jpg?x71639 241w" sizes="(max-width: 110px) 100vw, 110px" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
							<h3><a href="http://wired868.com/2017/01/02/aunt-phyllis-saintfiet-is-defaming-cyrus-tt-defender-had-just-one-glass-of-baileys/">Aunt Phyllis: Saintfiet is defaming Cyrus; T&#038;T defender had just one glass of Bailey’s!</a></h3>
				 <span class="tie-date"><i class="fa fa-clock-o"></i>Monday 2 January 2017</span>								<span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="http://wired868.com/2017/01/02/aunt-phyllis-saintfiet-is-defaming-cyrus-tt-defender-had-just-one-glass-of-baileys/#comments">426</a></span>
							</li>
		
				</ul>
			</div>
						<div id="tab3" class="tabs-wrap">
				<ul>
						<li>
		<div class="post-thumbnail" style="width:55px">
			<img alt='' src='http://graph.facebook.com/10152028561080951/picture' class='avatar avatar-55 photo' height='55' width='55' />		</div>
		<a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/#comment-157286">
		Lasana Liburd: Jamaal looks to have taken his exit. A pity. A little personality is no bad thin... </a>
	</li>
	<li>
		<div class="post-thumbnail" style="width:55px">
			<img alt='' src='http://graph.facebook.com/1352244048129265/picture' class='avatar avatar-55 photo' height='55' width='55' />		</div>
		<a href="http://wired868.com/2017/01/31/russia-2018-kenwyne-the-media-djw-wired868-reviews-lawrences-unveiling/#comment-157305">
		Dennis Juvenist Gilbert: Please drop jones... </a>
	</li>
	<li>
		<div class="post-thumbnail" style="width:55px">
			<img alt='' src='http://graph.facebook.com/10155499062410696/picture' class='avatar avatar-55 photo' height='55' width='55' />		</div>
		<a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/#comment-157291">
		Cherisse Moe: I'm willing to inno. I'm all for debates and hearing people's point of views but... </a>
	</li>
	<li>
		<div class="post-thumbnail" style="width:55px">
			<img alt='' src='http://graph.facebook.com/10156736708225374/picture' class='avatar avatar-55 photo' height='55' width='55' />		</div>
		<a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/#comment-157290">
		Brian Harry: Lasana Liburd all yuh hard boy! Cherise give the young man a bligh... </a>
	</li>
	<li>
		<div class="post-thumbnail" style="width:55px">
			<img alt='' src='http://graph.facebook.com/10152028561080951/picture' class='avatar avatar-55 photo' height='55' width='55' />		</div>
		<a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/#comment-157289">
		Lasana Liburd: He went from shutting us up to telling us we have to do more in a flash. Think h... </a>
	</li>
	<li>
		<div class="post-thumbnail" style="width:55px">
			<img alt='' src='http://graph.facebook.com/10155499062410696/picture' class='avatar avatar-55 photo' height='55' width='55' />		</div>
		<a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/#comment-157288">
		Cherisse Moe: Yh but his initial meme was kinda disrespectful n uncalled for..his later contri... </a>
	</li>
	<li>
		<div class="post-thumbnail" style="width:55px">
			<img alt='' src='http://graph.facebook.com/10155499062410696/picture' class='avatar avatar-55 photo' height='55' width='55' />		</div>
		<a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/#comment-157303">
		Cherisse Moe: I didnt know him before that speech so that was what I held onto.... </a>
	</li>
	<li>
		<div class="post-thumbnail" style="width:55px">
			<img alt='' src='http://graph.facebook.com/10156736708225374/picture' class='avatar avatar-55 photo' height='55' width='55' />		</div>
		<a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/#comment-157287">
		Brian Harry: Lasana Liburd I agree and he seemed youthful so it's a pity because it's up to u... </a>
	</li>
				</ul>
			</div>
						<div id="tab4" class="tabs-wrap tagcloud">
				<a href='http://wired868.com/tag/soca-warriors/' class='tag-link-66 tag-link-position-1' title='437 topics' style='font-size: 8pt;'>Soca Warriors</a>
<a href='http://wired868.com/tag/ttfa/' class='tag-link-1313 tag-link-position-2' title='304 topics' style='font-size: 8pt;'>TTFA</a>
<a href='http://wired868.com/tag/w-connection/' class='tag-link-148 tag-link-position-3' title='260 topics' style='font-size: 8pt;'>W Connection</a>
<a href='http://wired868.com/tag/central-fc/' class='tag-link-486 tag-link-position-4' title='235 topics' style='font-size: 8pt;'>Central FC</a>
<a href='http://wired868.com/tag/jack-warner/' class='tag-link-3 tag-link-position-5' title='234 topics' style='font-size: 8pt;'>Jack Warner</a>
<a href='http://wired868.com/tag/peoples-partnership/' class='tag-link-50 tag-link-position-6' title='228 topics' style='font-size: 8pt;'>People&#039;s Partnership</a>
<a href='http://wired868.com/tag/stephen-hart/' class='tag-link-1268 tag-link-position-7' title='211 topics' style='font-size: 8pt;'>Stephen Hart</a>
<a href='http://wired868.com/tag/kamla-persad-bissessar/' class='tag-link-43 tag-link-position-8' title='177 topics' style='font-size: 8pt;'>Kamla Persad-Bissessar</a>
<a href='http://wired868.com/tag/2018-world-cup/' class='tag-link-692 tag-link-position-9' title='167 topics' style='font-size: 8pt;'>2018 World Cup</a>
<a href='http://wired868.com/tag/raymond-tim-kee/' class='tag-link-596 tag-link-position-10' title='154 topics' style='font-size: 8pt;'>Raymond Tim Kee</a>
<a href='http://wired868.com/tag/defence-force/' class='tag-link-154 tag-link-position-11' title='144 topics' style='font-size: 8pt;'>Defence Force</a>
<a href='http://wired868.com/tag/david-john-williams/' class='tag-link-350 tag-link-position-12' title='142 topics' style='font-size: 8pt;'>David John Williams</a>
<a href='http://wired868.com/tag/keith-rowley/' class='tag-link-35 tag-link-position-13' title='134 topics' style='font-size: 8pt;'>Keith Rowley</a>
<a href='http://wired868.com/tag/trinidad-and-tobago-police/' class='tag-link-93 tag-link-position-14' title='128 topics' style='font-size: 8pt;'>Trinidad and Tobago police</a>
<a href='http://wired868.com/tag/olympics-2016/' class='tag-link-2396 tag-link-position-15' title='124 topics' style='font-size: 8pt;'>Olympics 2016</a>
<a href='http://wired868.com/tag/pnm/' class='tag-link-135 tag-link-position-16' title='124 topics' style='font-size: 8pt;'>PNM</a>
<a href='http://wired868.com/tag/caledonia-aia/' class='tag-link-73 tag-link-position-17' title='122 topics' style='font-size: 8pt;'>Caledonia AIA</a>
<a href='http://wired868.com/tag/jan-michael-williams/' class='tag-link-105 tag-link-position-18' title='112 topics' style='font-size: 8pt;'>Jan-Michael Williams</a>
<a href='http://wired868.com/tag/kenwyne-jones/' class='tag-link-296 tag-link-position-19' title='112 topics' style='font-size: 8pt;'>Kenwyne Jones</a>
<a href='http://wired868.com/tag/sheldon-phillips/' class='tag-link-1246 tag-link-position-20' title='110 topics' style='font-size: 8pt;'>Sheldon Phillips</a>
<a href='http://wired868.com/tag/ttff/' class='tag-link-7 tag-link-position-21' title='107 topics' style='font-size: 8pt;'>TTFF</a>
<a href='http://wired868.com/tag/ministry-of-sport/' class='tag-link-399 tag-link-position-22' title='104 topics' style='font-size: 8pt;'>Ministry of Sport</a>
<a href='http://wired868.com/tag/north-east-stars/' class='tag-link-158 tag-link-position-23' title='102 topics' style='font-size: 8pt;'>North East Stars</a>
<a href='http://wired868.com/tag/201314-pro-league/' class='tag-link-685 tag-link-position-24' title='96 topics' style='font-size: 8pt;'>2013/14 Pro League</a>
<a href='http://wired868.com/tag/brent-sancho/' class='tag-link-107 tag-link-position-25' title='95 topics' style='font-size: 8pt;'>Brent Sancho</a>			</div>
			
		</div>
	</div><!-- .widget /-->
<div id="video-widget-2" class="widget video-widget"><div class="widget-top"><h4>Featured Video</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><iframe width="320" height="180" src="https://www.youtube.com/embed/nlGKtNizSU4?feature=oembed" frameborder="0" allowfullscreen></iframe></div></div><!-- .widget /-->			<div id="text-html-widget-19" class="text-html-box" style="text-align:center;">
			<div style="float: left; " class="wired-sponsor-right advads-track" data-id="28884" id="wired-1743980085"><a href="http://wired868.com/linkout/28884" target="_blank"><img width="125" height="125" src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/10/TT-Pro-League-logo.jpg?x71639' alt='' title='TT Pro League logo' /></a></div> <div style="float: left; " class="wired-sponsor-left advads-track" data-id="28884" id="wired-1248969310"><a href="http://wired868.com/linkout/28884" target="_blank"><img width="125" height="125" src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/uploads/2015/10/TT-Pro-League-logo.jpg?x71639' alt='' title='TT Pro League logo' /></a></div>			</div>
		<div id="jr_insta_slider-2" class="widget jr-insta-slider"><div class="widget-top"><h4>Wired868 on Instagram</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><script type='text/javascript'>
	jQuery(document).ready(function($) {
		$('.instaslider-nr-2').pllexislider({
			animation: 'slide',
			slideshowSpeed: 7000,
			directionNav: true,
			controlNav: false,
			prevText: '',
			nextText: '',
		});
	});
</script>
<div class='pllexislider pllexislider-normal instaslider-nr-2'>
<ul class='no-bullet slides'>
<li><a href="https://www.instagram.com/p/BPeCpnFgXK3/" target="_blank" title="Boom! W Connection and Suriname international attacker Dimitrie Apai centrehellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/16123385_1251980504880179_3542287750688407552_n.jpg?ig_cache_key=MTQzMTU5MzM4NzExMDI2NTUyNw%3D%3D.2" alt="Boom! W Connection and Suriname international attacker Dimitrie Apai centrehellip" title="Boom! W Connection and Suriname international attacker Dimitrie Apai centrehellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>2 weeks ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Boom! W Connection and Suriname international attacker Dimitrie Apai (centre) takes a crack at goal during Pro League action against St Ann’s Rangers at the Hasely Crawford Stadium on 17 January 2017. Photo: Sean Morrison/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BQDE10agtfq/" target="_blank" title="Trinidad and Tobago Football Association TTFA president David JohnWilliams secondhellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/16230184_1871220939787038_104758276733796352_n.jpg?ig_cache_key=MTQ0MjAxNzU5NjI4NjM1OTUzMA%3D%3D.2" alt="Trinidad and Tobago Football Association TTFA president David JohnWilliams secondhellip" title="Trinidad and Tobago Football Association TTFA president David JohnWilliams secondhellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>4 hours ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Trinidad and Tobago Football Association (TTFA) president David John-Williams (second from right) poses with Women’s National Senior Team coaches (from left) Nicola Williams, Carolina Morace and Elisabetta Bavagnoli at a press conference on 1 February 2017. Photo: Sean Morrison/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPuxFZWgbC6/" target="_blank" title="Emperor Julius Central FC defender Julius James right looks forhellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/16110867_1070398846403471_5425235781583110144_n.jpg?ig_cache_key=MTQzNjMwMTIwNjI3NTMzODQyNg%3D%3D.2" alt="Emperor Julius Central FC defender Julius James right looks forhellip" title="Emperor Julius Central FC defender Julius James right looks forhellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>1 week ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Emperor Julius... Central FC defender Julius James (right) looks for passing options during Pro League action against Defence Force at the Ato Boldon Stadium, Couva on 24 January 2017. Photo: Chevaughn Christopher/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPtkR9EAQX5/" target="_blank" title="Oh shiiiiiit! Defence Force goalkeeper Sheldon Clarke watches in despairhellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/16110545_390149017999721_3261554162642452480_n.jpg?ig_cache_key=MTQzNTk2MzQxOTY3MTk4NzcwNQ%3D%3D.2" alt="Oh shiiiiiit! Defence Force goalkeeper Sheldon Clarke watches in despairhellip" title="Oh shiiiiiit! Defence Force goalkeeper Sheldon Clarke watches in despairhellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>1 week ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Oh shiiiiiit! Defence Force goalkeeper Sheldon Clarke watches in despair as Central FC forward Jason Marcano’s penalty flies past him during Pro League action at the Ato Boldon Stadium, Couva on 24 January 2017. Photo: Chevaughn Christopher/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BP-yOr-AOmD/" target="_blank" title="Who remembers old school dinner menus?"><img src="https://scontent.cdninstagram.com/t51.2885-15/sh0.08/e35/p750x750/16228647_242660006144378_6275702223167029248_n.jpg?ig_cache_key=MTQ0MDgwOTg0MjQxNDUxMjUxNQ%3D%3D.2" alt="Who remembers old school dinner menus?" title="Who remembers old school dinner menus?" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>2 days ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Who remembers 'old school' dinner menus?</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPanRLhAp6d/" target="_blank" title="Bend it like Jorsling! Morvant Caledonia United goalkeeper Marvin Philliphellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/16110547_773800889443823_1302493568891355136_n.jpg?ig_cache_key=MTQzMDYyODUzNjA1MzU3MTIyOQ%3D%3D.2" alt="Bend it like Jorsling! Morvant Caledonia United goalkeeper Marvin Philliphellip" title="Bend it like Jorsling! Morvant Caledonia United goalkeeper Marvin Philliphellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>2 weeks ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Bend it like Jorsling! Morvant Caledonia United goalkeeper Marvin Phillip (second from left) senses danger as Defence Force striker Devorn Jorsling (far right) lofts his free kick over the defensive wall during Pro League action at the Hasely Crawford Stadium on 17 January 2017. Photo: Sean Morrison/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPl9lgagLnA/" target="_blank" title="Hit the Roach! Club Sando forward Akeem Roach left ishellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/15876724_563850060487935_151843818516250624_n.jpg?ig_cache_key=MTQzMzgyMjkxNDY0OTU2OTcyOA%3D%3D.2" alt="Hit the Roach! Club Sando forward Akeem Roach left ishellip" title="Hit the Roach! Club Sando forward Akeem Roach left ishellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>2 weeks ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Hit the Roach! Club Sando forward Akeem Roach (left) is tackled by Police FC midfielder Kareem Freitas during Pro League action at the Larry Gomes Stadium on 22 January 2017. Photo: Sean Morrison/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPc7WSDgZwU/" target="_blank" title="MVPs! Secondary Schools Football League SSFL 2016 MVPs Kedie Johnsonhellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/s480x480/e35/14624630_688388904668960_7658451057030201344_n.jpg?ig_cache_key=MTQzMTI3OTc5NzU1NTc5NzAxMg%3D%3D.2" alt="MVPs! Secondary Schools Football League SSFL 2016 MVPs Kedie Johnsonhellip" title="MVPs! Secondary Schools Football League SSFL 2016 MVPs Kedie Johnsonhellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>2 weeks ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>MVPs! Secondary Schools Football League (SSFL) 2016 MVPs Ke'die Johnson (left) and Tyrel "Pappy" Emmanuel pose with their silverware at the National Cycling Centre in Balmain on 18 January 2017. Johnson is a St Augustine Secondary attacker while Emmanuel plays midfield for Shiva Boys Hindu College. Photo: Sean Morrison/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPs8ab2gpbp/" target="_blank" title="Oh gorm doh take it so hard! Jamaicas 4x100 teamhellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/s750x750/sh0.08/e35/16123650_1908221736079827_1691865361097424896_n.jpg?ig_cache_key=MTQzNTc4ODA4MDYyNjk2NDIwMQ%3D%3D.2" alt="Oh gorm doh take it so hard! Jamaicas 4x100 teamhellip" title="Oh gorm doh take it so hard! Jamaicas 4x100 teamhellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>1 week ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Oh gorm... doh take it so hard! Jamaica's 4x100 team, including legend Usain Bolt, will be stripped of Beijing Olympic gold medals after Nesta Carter failed drug test.</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPc7xgCg1oI/" target="_blank" title="Soldier boy! Defence Force attacker Jamille Boatswain left and Morvanthellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/16123868_1789006038091340_9186184629458042880_n.jpg?ig_cache_key=MTQzMTI4MTY2Nzk5NzM5MTM2OA%3D%3D.2" alt="Soldier boy! Defence Force attacker Jamille Boatswain left and Morvanthellip" title="Soldier boy! Defence Force attacker Jamille Boatswain left and Morvanthellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>2 weeks ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Soldier boy! Defence Force attacker Jamille Boatswain (left) and Morvant Caledonia United defender Taje Commissiong contest the ball during Pro League action at the Hasely Crawford Stadium on 17 January 2017. Photo: Sean Morrison/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPtzfBagTvI/" target="_blank" title="Showtime! Central FC forward Jason Marcano foreground holds off Defencehellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/16230456_855088454632945_4178961307371831296_n.jpg?ig_cache_key=MTQzNjAzMDI4ODM5NTMyMDI2NA%3D%3D.2" alt="Showtime! Central FC forward Jason Marcano foreground holds off Defencehellip" title="Showtime! Central FC forward Jason Marcano foreground holds off Defencehellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>1 week ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Showtime! Central FC forward Jason Marcano (foreground) holds off Defence Force defender Jamali Garcia during Pro League action at the Ato Boldon Stadium, Couva on 24 January 2017. Photo: Chevaughn Christopher/Wired868</span>
</div>
</li><li><a href="https://www.instagram.com/p/BPz5uPugjww/" target="_blank" title="Central FC forward Rundell Winchester left prepares to surprise Defencehellip"><img src="https://scontent.cdninstagram.com/t51.2885-15/e35/16229082_111861949328575_1513892950122168320_n.jpg?ig_cache_key=MTQzNzc0NjU3MjY5NDc5NzM2MA%3D%3D.2" alt="Central FC forward Rundell Winchester left prepares to surprise Defencehellip" title="Central FC forward Rundell Winchester left prepares to surprise Defencehellip" /></a><div class='jr-insta-datacontainer'>
<span class='jr-insta-time'>6 days ago</span>
<span class='jr-insta-username'>by <a rel='nofollow' href='https://www.instagram.com/wired868/' target='_blank'>wired868</a></span>
<span class='jr-insta-caption'>Central FC forward Rundell Winchester (left) prepares to surprise Defence Force midfielder Kerry Joseph (centre) by rolling the ball backwards through his legs during Pro League action at the Ato Boldon Stadium, Couva on 24 January 2017. By the end of the move, an irate Winchester was ejected for dissent by referee Cecile Hinds. Photo: Chevaughn Christopher/Wired868</span>
</div>
</li></ul>
</div></div></div><!-- .widget /--><div id="facebook-widget-2" class="widget facebook-widget"><div class="widget-top"><h4>Find us on Facebook		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="facebook-box">
				<iframe src="http://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/Wired868/&amp;width=300&amp;height=250&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->			<div id="text-html-widget-22" class="text-html-box" >
						</div>
		<div id="archives-3" class="widget widget_archive"><div class="widget-top"><h4>Archives</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://wired868.com/2017/02/'> February 2017 </option>
	<option value='http://wired868.com/2017/01/'> January 2017 </option>
	<option value='http://wired868.com/2016/12/'> December 2016 </option>
	<option value='http://wired868.com/2016/11/'> November 2016 </option>
	<option value='http://wired868.com/2016/10/'> October 2016 </option>
	<option value='http://wired868.com/2016/09/'> September 2016 </option>
	<option value='http://wired868.com/2016/08/'> August 2016 </option>
	<option value='http://wired868.com/2016/07/'> July 2016 </option>
	<option value='http://wired868.com/2016/06/'> June 2016 </option>
	<option value='http://wired868.com/2016/05/'> May 2016 </option>
	<option value='http://wired868.com/2016/04/'> April 2016 </option>
	<option value='http://wired868.com/2016/03/'> March 2016 </option>
	<option value='http://wired868.com/2016/02/'> February 2016 </option>
	<option value='http://wired868.com/2016/01/'> January 2016 </option>
	<option value='http://wired868.com/2015/12/'> December 2015 </option>
	<option value='http://wired868.com/2015/11/'> November 2015 </option>
	<option value='http://wired868.com/2015/10/'> October 2015 </option>
	<option value='http://wired868.com/2015/09/'> September 2015 </option>
	<option value='http://wired868.com/2015/08/'> August 2015 </option>
	<option value='http://wired868.com/2015/07/'> July 2015 </option>
	<option value='http://wired868.com/2015/06/'> June 2015 </option>
	<option value='http://wired868.com/2015/05/'> May 2015 </option>
	<option value='http://wired868.com/2015/04/'> April 2015 </option>
	<option value='http://wired868.com/2015/03/'> March 2015 </option>
	<option value='http://wired868.com/2015/02/'> February 2015 </option>
	<option value='http://wired868.com/2015/01/'> January 2015 </option>
	<option value='http://wired868.com/2014/12/'> December 2014 </option>
	<option value='http://wired868.com/2014/11/'> November 2014 </option>
	<option value='http://wired868.com/2014/10/'> October 2014 </option>
	<option value='http://wired868.com/2014/09/'> September 2014 </option>
	<option value='http://wired868.com/2014/08/'> August 2014 </option>
	<option value='http://wired868.com/2014/07/'> July 2014 </option>
	<option value='http://wired868.com/2014/06/'> June 2014 </option>
	<option value='http://wired868.com/2014/05/'> May 2014 </option>
	<option value='http://wired868.com/2014/04/'> April 2014 </option>
	<option value='http://wired868.com/2014/03/'> March 2014 </option>
	<option value='http://wired868.com/2014/02/'> February 2014 </option>
	<option value='http://wired868.com/2014/01/'> January 2014 </option>
	<option value='http://wired868.com/2013/12/'> December 2013 </option>
	<option value='http://wired868.com/2013/11/'> November 2013 </option>
	<option value='http://wired868.com/2013/10/'> October 2013 </option>
	<option value='http://wired868.com/2013/09/'> September 2013 </option>
	<option value='http://wired868.com/2013/08/'> August 2013 </option>
	<option value='http://wired868.com/2013/07/'> July 2013 </option>
	<option value='http://wired868.com/2013/06/'> June 2013 </option>
	<option value='http://wired868.com/2013/05/'> May 2013 </option>
	<option value='http://wired868.com/2013/04/'> April 2013 </option>
	<option value='http://wired868.com/2013/03/'> March 2013 </option>
	<option value='http://wired868.com/2013/02/'> February 2013 </option>
	<option value='http://wired868.com/2013/01/'> January 2013 </option>
	<option value='http://wired868.com/2012/12/'> December 2012 </option>
	<option value='http://wired868.com/2012/11/'> November 2012 </option>
	<option value='http://wired868.com/2012/10/'> October 2012 </option>
	<option value='http://wired868.com/2012/09/'> September 2012 </option>
	<option value='http://wired868.com/2012/08/'> August 2012 </option>
	<option value='http://wired868.com/2012/07/'> July 2012 </option>
	<option value='http://wired868.com/2012/06/'> June 2012 </option>
	<option value='http://wired868.com/2012/05/'> May 2012 </option>
	<option value='http://wired868.com/2012/04/'> April 2012 </option>
	<option value='http://wired868.com/2012/03/'> March 2012 </option>
	<option value='http://wired868.com/2012/02/'> February 2012 </option>
	<option value='http://wired868.com/2012/01/'> January 2012 </option>

		</select>
		</div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-3c">

			<div id="footer-first" class="footer-widgets-box">
			<div id="tag_cloud-8" class="footer-widget widget_tag_cloud"><div class="footer-widget-top"><h4>Cloud 868</h4></div>
						<div class="footer-widget-container"><div class="tagcloud"><a href='http://wired868.com/tag/201213-pro-league/' class='tag-link-485 tag-link-position-1' title='79 topics' style='font-size: 9.51807228916pt;'>2012/13 Pro League</a>
<a href='http://wired868.com/tag/2013-gold-cup/' class='tag-link-641 tag-link-position-2' title='79 topics' style='font-size: 9.51807228916pt;'>2013 Gold Cup</a>
<a href='http://wired868.com/tag/201314-pro-league/' class='tag-link-685 tag-link-position-3' title='96 topics' style='font-size: 11.0361445783pt;'>2013/14 Pro League</a>
<a href='http://wired868.com/tag/201516-pro-league/' class='tag-link-2472 tag-link-position-4' title='73 topics' style='font-size: 9.01204819277pt;'>2015/16 Pro League</a>
<a href='http://wired868.com/tag/2018-world-cup/' class='tag-link-692 tag-link-position-5' title='167 topics' style='font-size: 15.0843373494pt;'>2018 World Cup</a>
<a href='http://wired868.com/tag/angus-eve/' class='tag-link-53 tag-link-position-6' title='64 topics' style='font-size: 8pt;'>Angus Eve</a>
<a href='http://wired868.com/tag/anil-roberts/' class='tag-link-52 tag-link-position-7' title='80 topics' style='font-size: 9.68674698795pt;'>Anil Roberts</a>
<a href='http://wired868.com/tag/brent-sancho/' class='tag-link-107 tag-link-position-8' title='95 topics' style='font-size: 10.8674698795pt;'>Brent Sancho</a>
<a href='http://wired868.com/tag/caledonia-aia/' class='tag-link-73 tag-link-position-9' title='122 topics' style='font-size: 12.7228915663pt;'>Caledonia AIA</a>
<a href='http://wired868.com/tag/central-fc/' class='tag-link-486 tag-link-position-10' title='235 topics' style='font-size: 17.4457831325pt;'>Central FC</a>
<a href='http://wired868.com/tag/david-john-williams/' class='tag-link-350 tag-link-position-11' title='142 topics' style='font-size: 13.9036144578pt;'>David John Williams</a>
<a href='http://wired868.com/tag/defence-force/' class='tag-link-154 tag-link-position-12' title='144 topics' style='font-size: 13.9036144578pt;'>Defence Force</a>
<a href='http://wired868.com/tag/devorn-jorsling/' class='tag-link-343 tag-link-position-13' title='64 topics' style='font-size: 8pt;'>Devorn Jorsling</a>
<a href='http://wired868.com/tag/fifa-corruption/' class='tag-link-17 tag-link-position-14' title='70 topics' style='font-size: 8.67469879518pt;'>FIFA corruption</a>
<a href='http://wired868.com/tag/jack-warner/' class='tag-link-3 tag-link-position-15' title='234 topics' style='font-size: 17.4457831325pt;'>Jack Warner</a>
<a href='http://wired868.com/tag/jamaal-shabazz/' class='tag-link-438 tag-link-position-16' title='79 topics' style='font-size: 9.51807228916pt;'>Jamaal Shabazz</a>
<a href='http://wired868.com/tag/jan-michael-williams/' class='tag-link-105 tag-link-position-17' title='112 topics' style='font-size: 12.0481927711pt;'>Jan-Michael Williams</a>
<a href='http://wired868.com/tag/joevin-jones/' class='tag-link-152 tag-link-position-18' title='94 topics' style='font-size: 10.8674698795pt;'>Joevin Jones</a>
<a href='http://wired868.com/tag/kamla-persad-bissessar/' class='tag-link-43 tag-link-position-19' title='177 topics' style='font-size: 15.421686747pt;'>Kamla Persad-Bissessar</a>
<a href='http://wired868.com/tag/keith-rowley/' class='tag-link-35 tag-link-position-20' title='134 topics' style='font-size: 13.3975903614pt;'>Keith Rowley</a>
<a href='http://wired868.com/tag/kenwyne-jones/' class='tag-link-296 tag-link-position-21' title='112 topics' style='font-size: 12.0481927711pt;'>Kenwyne Jones</a>
<a href='http://wired868.com/tag/martin-daly/' class='tag-link-1679 tag-link-position-22' title='66 topics' style='font-size: 8.33734939759pt;'>Martin Daly</a>
<a href='http://wired868.com/tag/ministry-of-sport/' class='tag-link-399 tag-link-position-23' title='104 topics' style='font-size: 11.5421686747pt;'>Ministry of Sport</a>
<a href='http://wired868.com/tag/north-east-stars/' class='tag-link-158 tag-link-position-24' title='102 topics' style='font-size: 11.3734939759pt;'>North East Stars</a>
<a href='http://wired868.com/tag/olympics-2016/' class='tag-link-2396 tag-link-position-25' title='124 topics' style='font-size: 12.8915662651pt;'>Olympics 2016</a>
<a href='http://wired868.com/tag/one-on-one/' class='tag-link-1464 tag-link-position-26' title='78 topics' style='font-size: 9.51807228916pt;'>One on one</a>
<a href='http://wired868.com/tag/peoples-partnership/' class='tag-link-50 tag-link-position-27' title='228 topics' style='font-size: 17.2771084337pt;'>People&#039;s Partnership</a>
<a href='http://wired868.com/tag/pnm/' class='tag-link-135 tag-link-position-28' title='124 topics' style='font-size: 12.8915662651pt;'>PNM</a>
<a href='http://wired868.com/tag/point-fortin-civic/' class='tag-link-1166 tag-link-position-29' title='70 topics' style='font-size: 8.67469879518pt;'>Point Fortin Civic</a>
<a href='http://wired868.com/tag/police-fc/' class='tag-link-1169 tag-link-position-30' title='75 topics' style='font-size: 9.18072289157pt;'>Police FC</a>
<a href='http://wired868.com/tag/raymond-tim-kee/' class='tag-link-596 tag-link-position-31' title='154 topics' style='font-size: 14.4096385542pt;'>Raymond Tim Kee</a>
<a href='http://wired868.com/tag/san-juan-jabloteh/' class='tag-link-498 tag-link-position-32' title='83 topics' style='font-size: 9.85542168675pt;'>San Juan Jabloteh</a>
<a href='http://wired868.com/tag/sheldon-phillips/' class='tag-link-1246 tag-link-position-33' title='110 topics' style='font-size: 12.0481927711pt;'>Sheldon Phillips</a>
<a href='http://wired868.com/tag/soca-warriors/' class='tag-link-66 tag-link-position-34' title='437 topics' style='font-size: 22pt;'>Soca Warriors</a>
<a href='http://wired868.com/tag/st-anns-rangers/' class='tag-link-558 tag-link-position-35' title='77 topics' style='font-size: 9.34939759036pt;'>St Ann&#039;s Rangers</a>
<a href='http://wired868.com/tag/stephen-hart/' class='tag-link-1268 tag-link-position-36' title='211 topics' style='font-size: 16.7710843373pt;'>Stephen Hart</a>
<a href='http://wired868.com/tag/stuart-charles-fevrier/' class='tag-link-63 tag-link-position-37' title='69 topics' style='font-size: 8.67469879518pt;'>Stuart Charles-Fevrier</a>
<a href='http://wired868.com/tag/trinidad-and-tobago-media/' class='tag-link-23 tag-link-position-38' title='90 topics' style='font-size: 10.5301204819pt;'>Trinidad and Tobago media</a>
<a href='http://wired868.com/tag/trinidad-and-tobago-police/' class='tag-link-93 tag-link-position-39' title='128 topics' style='font-size: 13.0602409639pt;'>Trinidad and Tobago police</a>
<a href='http://wired868.com/tag/ttfa/' class='tag-link-1313 tag-link-position-40' title='304 topics' style='font-size: 19.3012048193pt;'>TTFA</a>
<a href='http://wired868.com/tag/ttff/' class='tag-link-7 tag-link-position-41' title='107 topics' style='font-size: 11.7108433735pt;'>TTFF</a>
<a href='http://wired868.com/tag/unc/' class='tag-link-208 tag-link-position-42' title='70 topics' style='font-size: 8.67469879518pt;'>UNC</a>
<a href='http://wired868.com/tag/w-connection/' class='tag-link-148 tag-link-position-43' title='260 topics' style='font-size: 18.2891566265pt;'>W Connection</a>
<a href='http://wired868.com/tag/wired868-profile/' class='tag-link-1472 tag-link-position-44' title='82 topics' style='font-size: 9.85542168675pt;'>Wired868 profile</a>
<a href='http://wired868.com/tag/women-soca-warriors/' class='tag-link-2060 tag-link-position-45' title='82 topics' style='font-size: 9.85542168675pt;'>Women Soca Warriors</a></div>
</div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="recent-comments-2" class="footer-widget widget_recent_comments"><div class="footer-widget-top"><h4>Recent Comments</h4></div>
						<div class="footer-widget-container"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='http://www.facebook.com/10152028561080951' rel='external nofollow' class='url'>Lasana Liburd</a></span> on <a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/comment-page-1/#comment-157286">“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.facebook.com/1352244048129265' rel='external nofollow' class='url'>Dennis Juvenist Gilbert</a></span> on <a href="http://wired868.com/2017/01/31/russia-2018-kenwyne-the-media-djw-wired868-reviews-lawrences-unveiling/comment-page-1/#comment-157305">Russia 2018, Kenwyne, the media, DJW… Wired868 reviews Lawrence’s unveiling</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.facebook.com/10155499062410696' rel='external nofollow' class='url'>Cherisse Moe</a></span> on <a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/comment-page-1/#comment-157291">“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.facebook.com/10156736708225374' rel='external nofollow' class='url'>Brian Harry</a></span> on <a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/comment-page-1/#comment-157290">“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.facebook.com/10152028561080951' rel='external nofollow' class='url'>Lasana Liburd</a></span> on <a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/comment-page-1/#comment-157289">“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.facebook.com/10155499062410696' rel='external nofollow' class='url'>Cherisse Moe</a></span> on <a href="http://wired868.com/2017/02/01/torpedo-we-feel-the-sport-ministry-is-deliberately-stiff-arming-national-athletes/comment-page-1/#comment-157288">“Torpedo”: We feel the Sport Ministry is deliberately ‘stiff-arming’ national athletes</a></li></ul></div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

			<div id="footer-third" class="footer-widgets-box">
			<div id="twitter-2" class="footer-widget widget_twitter"><div><div class="footer-widget-top"><h4><span class='twitterwidget twitterwidget-title'>Wired868 @ Twitter</span></h4></div>
						<div class="footer-widget-container"><ul><li><span class='entry-content'>Limited thinking! Columnist Sheldon Waithe suggests why T&amp;T governments get nowhere in "war on crime" <a href="https://t.co/2IJ6q9RRjp" target="_blank">https://t.co/2IJ6q9RRjp</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/Wired868/statuses/827535436675420160" target="_blank">about 11 minutes ago</a></span> <span class='from-meta'>from <a href="http://www.facebook.com/twitter" rel="nofollow">Facebook</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=827535436675420160" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=827535436675420160" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=827535436675420160" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'>Italian Carolina Morace brings three foreign coaches on T&amp;T women’s staff; DJW says CONCACAF cash will cover costs <a href="https://t.co/TLqjUM0anz" target="_blank">https://t.co/TLqjUM0anz</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/Wired868/statuses/827256503203557378" target="_blank">04:44:54 PM February 02, 2017</a></span> <span class='from-meta'>from <a href="http://www.facebook.com/twitter" rel="nofollow">Facebook</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=827256503203557378" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=827256503203557378" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=827256503203557378" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'>Many Rivers to cross: Club Sando star, Kemuel Rivers, talks about football, life, his late brother, Isaiah, God…... <a href="https://t.co/G17RcaWDON" target="_blank">https://t.co/G17RcaWDON</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/Wired868/statuses/827192997158719488" target="_blank">12:32:33 PM February 02, 2017</a></span> <span class='from-meta'>from <a href="http://www.facebook.com/twitter" rel="nofollow">Facebook</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=827192997158719488" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=827192997158719488" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=827192997158719488" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li></ul><div class="follow-button"><a href="http://twitter.com/wired868" class="twitter-follow-button" title="Follow @wired868" data-lang="en" target="_blank">@wired868</a></div></div></div></div><!-- .widget /-->		</div><!-- #third .widget-area -->
	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="http://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>		</div>
				<div class="social-icons">
		<a class="ttip-none" title="Rss" href="http://wired868.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/u/0/106801319776179833488/posts" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/Wired868/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/Wired868" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="LinkedIn" href="https://www.linkedin.com/in/lasana-liburd-b00291b" target="_blank"><i class="fa fa-linkedin"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/wired868/" target="_blank"><i class="tieicon-instagram"></i></a>		
			</div>

		
		<div class="alignleft">
			© Copyright 2017, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-31918706-1', 'auto');
  ga('send', 'pageview');

</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/wired868.com\/2017\/02\/03\/limited-thinking-why-tt-governments-get-nowhere-in-war-on-crime\/":36198};
	</script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/cresta-social-share-counter/js/jquery.cresta-social-effect.js?x71639'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/sportspress/assets/js/jquery.dataTables.min.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/sportspress/assets/js/jquery.countdown.min.js?x71639'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var localized_strings = {"days":"days","hrs":"hrs","mins":"mins","secs":"secs","previous":"Previous","next":"Next"};
/* ]]> */
</script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/sportspress/assets/js/sportspress.js?x71639'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/js/tie-scripts.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/js/ilightbox.packed.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/js/validation.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-includes/js/comment-reply.min.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-includes/js/wp-embed.min.js?x71639'></script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/themes/sahifa/js/search.js?x71639'></script>
<script type='text/javascript' src='http://platform.twitter.com/widgets.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?x71639'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var cptch_vars = {"nonce":"ef8c09e130","ajaxurl":"http:\/\/wired868.com\/wp-admin\/admin-ajax.php","enlarge":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com/wp-content/plugins/captcha/js/front_end_script.js?x71639'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201705.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'63908312',post:'36198',tz:'-4',srv:'wired868.com'} ]);
	_stq.push([ 'clickTrackerInit', '63908312', '36198' ]);
</script>
</body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 6916/8028 objects using disk
Page Caching using disk: enhanced
Content Delivery Network via 927c7056a6505e51f411252c.gaut33cm2m.netdna-cdn.com
Minified using disk
Database Caching 2/225 queries in 1.242 seconds using disk

 Served from: wired868.com @ 2017-02-03 11:25:11 by W3 Total Cache -->